Project Workspace

Figure 1. Project Workspace Toolbar.

Watch the video tutorial on AnimatLabs user interface!

Project Workspace Description

The project workspace is where you go to configure the main properties for the simulation project. The simulation is shown in the Hierarchy tree view and is split up into several sections. Please click on any of the sections below for a more detailed description.

This node has a couple of parameters that are applied to the entire project, yet do not belong to the environment.

This node has a number of properties to configure the virtual environment. This includes things like gravity, organisms, and structures.

This is a list of all the biomechanical organisms in the simulation. Click here for a more details on the properties of an organism.

This is a list of all the structures in the simulation. Click here for a more details on the properties of a structure.

Playback Control
This item allows you to control the playback speed of the simulation.

This has a list of all Stimuli that have been added to objects in the project. Click here to find out more about stimuli.

Data Tools
This has a list of all Data Tools that have been added to the system. Data tools allow you to view and analyze data.

There is also a properties section. Whenever you click on an item in the project workspace the properties for that item are displayed. At the bottom there is also a tab where you can switch to see the Project Toolbox. This contains a list of all Data Tools that can be used in this project. Double click any of the tools to add a new one to your project.

Using the Docking Toolbars

Figure 2. The docking toolbar.

The user interface for AnimatLab uses docking toolbars extensively throughout the application. These toolbars allow you to make much better use of the available space on the screen. By having the toolbar collapsed it is still readily available, but it is out of the way unless you need it. The toolbars can also be docked and layered anywhere in the workspace. This lets you configure the environment to meet your needs. If you want the project workspace on the left side of the screen instead of the right side then just move it over there and when you open the project up again it will be where you left it.

So how do you use these toolbars though? A toolbar can either be in an expanded or collapsed state. This is controlled by the push-pin icon in the top-right of the toolbar seen in figure 2. If you push in the pin then the toolbar is locked to the expanded state. If you push it back out then it is collapsed. When a toolbar is collapsed it will temporarily open up for you if you move the cursor over the tab. When you move the cursor off the toolbar it will close back down again.

You can also move the toolbars to different locations. To do this the toolbar must be pinned open. Then click on the toolbar title bar and drag it to a new place in the workspace where you want to place it. When it is located in a usable docking position you will see a grey rectangle that outlines where the bar will be located when you release the mouse button. You can also change the configuration of the toolbars to stack them on top of each other or layer them. You do this the same way. Simply drag the toolbar to where you want it to be and the grey rectangle will tell you where it will be docked to when you release the button.

Running Simulations

Figure 3. The simulation control bar.

There are several ways to run a simulation. The easiest method is to hit the play button on the simulation control bar shown in figure 3. This has a progress bar that displays the current simulation time. when the simulation starts the stop and pause buttons are enabled to let you control the simulation. Another way to start the simulation is go to the View menu item and select the Run Simulation item. You can also start the simulation directly using the keyboard shortcut F5. To start the simulation paused use shortcut F6, and to toggle the simulation between running and paused use the shortcut key F7.

Figure 4. View menu for starting simulations.

Creating a New Project

To Create a new project hit the New Project button, , on the toolbar to open the new project dialog box. Animatlabs files operate slightly differently from typical applications you may be used to like Microsoft Word and Excel. AnimatLab creates a project folder and the configuration for the project is split between multiple files. So to copy a project you need to copy all the files in the folder. Because of this, when you want to create a new project you need to specify the folder where you want the project folder created. Then specify the name of the project. AnimatLab creates a new folder using the name you specified and creates the necessary files inside that folder.

Figure 5. New Project Dialog.

Project Menus & Toolbars

The following items can be found in the main toolbar, main menu, and also in pop-up menus. You can view pop-up menus by selecting items in the Hierarchy tree and then right clicking on them to display the pop-up menu.

New Project
This closes the current project and opens the new project dialog. See the section on Creating A New Project.

Open Project
Displays the file open dialog to allow the user to choose an existing project file to open.

Save Project
Saves the current project.

Save As Project
Saves a copy of the current project using a different name or in a different location.

Close Project
Closes the currently open project.

Export Stand-Alone Simulation File
This exports a standalone simulation file that can be run using the stand-alone simulator.

Closes the application.

Add Organism
Adds a new organism to the project.

Add Structure
Adds a new structure to the project.

Add DataTool
Adds a new data tool to the project.

Cut Item From Workspace
Use this button to delete the select item from the workspace.